Quando trabalha com a nossa equipa de Suporte para resolver problemas que está a ter na nossa plataforma, como, por exemplo, desconexões de canais, a nossa equipa poderá pedir-lhe que forneça um ficheiro HTTP Archive, ou ficheiro HAR, e um registo da consola. Um ficheiro HAR é um registo da atividade de rede (pedidos e respostas) gerada pelo seu browser quando acede a diferentes sites ou inicia sessão em plataformas Web, como as suas contas de redes sociais ou o Cision/Brandwatch. O registo da consola regista quaisquer mensagens de código e erros encontrados pela rede.
Estes registos de dados podem ser valiosos para as nossas equipas técnicas, ajudando-as a resolver os problemas de ligação que possa estar a ter na nossa plataforma. Neste artigo, saiba como criar e exportar um ficheiro HAR e um registo da consola a partir de diferentes browsers e como os enviar à nossa equipa de Suporte.
Criar um ficheiro HAR
O processo de exportação de um ficheiro HAR varia ligeiramente consoante o browser utilizado.
Criar e exportar um ficheiro HAR a partir do Chrome
Aceda à página do browser Chrome onde está a ocorrer o problema, clique com o botão direito do rato na página e selecione Inspecionar.
Em alternativa, clique em Personalizar e controlar o Google Chrome (ícone dos três pontos), no canto superior direito do Chrome, e selecione Mais ferramentas > Ferramentas de programador.
As Ferramentas de programador do Chrome serão abertas num painel na página. Selecione o separador Rede, na parte superior do painel, e certifique-se de que o ícone Gravar, no canto superior esquerdo do separador Rede, está vermelho (a gravação está ativa).
Selecione a caixa de verificação Preservar registo, caso ainda não esteja selecionada.
Clique em Limpar registo de rede (ícone de círculo riscado) para limpar os pedidos antigos do registo de rede.
Reproduza o problema no seu browser enquanto o registo de rede está a ser gravado.
Clique no ícone Transferir. Quando passar o cursor sobre o ícone, será apresentada a opção Exportar HAR...
Atribua um nome exclusivo ao ficheiro e guarde-o no seu dispositivo.
Capturar o registo da consola no Chrome
Pode aceder ao registo da consola através do separador Consola nas Ferramentas de programador do Chrome e fazer uma captura de ecrã para a enviar à equipa de Suporte.
Nas Ferramentas de programador, clique no separador Consola.
Faça uma captura de ecrã do registo da consola (Cmd + Shift + 4 no Mac ou tecla Windows + Shift + S no Windows para capturar uma parte do ecrã).
Por predefinição, a captura de ecrã será guardada no Ambiente de Trabalho, no Mac, ou na pasta Utilizador/Imagens/Capturas de ecrã, no Windows. Certifique-se de que atribui um nome exclusivo ao ficheiro.
Criar e exportar um ficheiro HAR a partir do Firefox
Aceda à página do browser Firefox onde está a ocorrer o problema, clique com o botão direito do rato na página e selecione Inspecionar.
Em alternativa, selecione Ferramentas > Ferramentas do browser > Ferramentas de desenvolvimento Web (Tools > Browser Tools > Web Developer Tools) no menu de navegação superior do Firefox.
As Ferramentas de desenvolvimento Web do Firefox serão abertas num painel na página. Selecione o separador Rede, na parte superior do painel.
Reproduza o problema no seu browser enquanto o registo de rede está a ser gravado.
Clique em Definições de rede (ícone de engrenagem), no lado direito do painel, e selecione Guardar tudo como HAR.
Nota: Se esta opção estiver desativada (a cinzento), atualize a página e reproduza o problema para gerar o registo de rede. A opção Guardar tudo como HAR deverá então ficar disponível.
Atribua um nome exclusivo ao ficheiro e guarde-o no seu dispositivo.
Capturar o registo da consola no Firefox
Pode aceder ao registo da consola através do separador Consola nas Ferramentas de desenvolvimento Web do Firefox e fazer uma captura de ecrã para a enviar à equipa de Suporte.
Nas Ferramentas de desenvolvimento Web do Firefox, clique no separador Consola.
Faça uma captura de ecrã do registo da consola (Cmd + Shift + 4 no Mac ou tecla Windows + Shift + S no Windows para capturar uma parte do ecrã).
Por predefinição, a captura de ecrã será guardada no Ambiente de Trabalho, no Mac, ou na pasta Utilizador/Imagens/Capturas de ecrã, no Windows. Certifique-se de que atribui um nome exclusivo ao ficheiro.
Criar e exportar um ficheiro HAR a partir do Safari
Aceda à página do browser Safari onde está a ocorrer o problema. Em seguida, selecione o menu Desenvolvimento, na barra de navegação superior do Safari, e depois Ligar o Inspetor Web.
Nota: Se não vir a opção Desenvolvimento na barra de navegação superior do Safari, selecione Safari > Definições. No menu Definições, selecione o separador Avançadas (Advanced) e, em seguida, selecione a caixa de verificação Mostrar funcionalidades para programadores Web, na parte inferior do separador.
No Inspetor Web, selecione o separador Rede.
Reproduza o problema no seu browser enquanto o registo de rede está a ser gravado.
Clique em Exportar (Export), no lado direito do painel, para exportar o ficheiro HAR.
Nota: Se esta opção estiver desativada (a cinzento), atualize a página e reproduza o problema para gerar o registo de rede. O botão Exportar deverá então ficar disponível.
Atribua um nome exclusivo ao ficheiro e guarde-o no seu dispositivo.
Capturar o registo da consola no Safari
Pode aceder ao registo da consola através do separador Consola no Inspetor Web do Safari e fazer uma captura de ecrã para a enviar à equipa de Suporte.
No Inspetor Web, clique no separador Consola.
Faça uma captura de ecrã do registo da consola (Cmd + Shift + 4 no Mac ou tecla Windows + Shift + S no Windows para capturar uma parte do ecrã).
Por predefinição, a captura de ecrã será guardada no Ambiente de Trabalho, no Mac, ou na pasta Imagens/Capturas de ecrã, no Windows. Certifique-se de que atribui um nome exclusivo ao ficheiro.
Criar e exportar um ficheiro HAR a partir do Edge
Aceda à página do browser Edge onde está a ocorrer o problema, clique com o botão direito do rato na página e selecione Inspecionar.
Em alternativa, selecione Ferramentas > Ferramentas do browser > Ferramentas de desenvolvimento Web no menu de navegação superior do Edge.
As Ferramentas de programador do Edge serão abertas num painel na página. Selecione o separador Rede nas Ferramentas de programador e certifique-se de que o ícone Gravar, no canto superior esquerdo do separador Rede, está vermelho.
Selecione a caixa de verificação Preservar registo, caso ainda não esteja selecionada.
Clique em Limpar registo de rede (ícone de círculo riscado) para limpar os pedidos antigos do registo de rede.
Reproduza o problema no seu browser enquanto o registo de rede está a ser gravado.
Clique no ícone Exportar. Quando passar o cursor sobre o ícone, será apresentada a opção Exportar HAR...
Atribua um nome exclusivo ao ficheiro e guarde-o no seu dispositivo.
Capturar o registo da consola no Edge
Pode aceder ao registo da consola através do separador Consola (Console) nas Ferramentas de programador do Edge e fazer uma captura de ecrã para a enviar à equipa de Suporte.
In DevTools, click the Console tab.
Screenshot the console log (Cmd + Shift + 4 on Mac or Windows key + Shift + S on Windows to screenshot a portion of the screen).
By default, your screenshot will save to your Desktop on Mac or your user/Pictures/Screenshots folder on Windows. Be sure to rename the file with a unique name.
Providing a HAR file to our Support team
Once you have your HAR file, you can provide it to our Support team by uploading it and attaching it to your Support ticket or sending it to us as an email attachment.
Warning: HAR files may contain sensitive information about your browsing session. Please review the file before sharing and ensure it is shared securely.













